• PiperForum.com is a vibrant community of Piper owners and pilots. Our over 1,500+ active members use Piper Forum to swap technical knowledge, plan meetups and sell planes/parts. We host technical knowledge of general aviation topics and specific topics on J3-Cubs, Cherokees, Comanches, Pacers and more. In addition to an instant community of pilots for you, PiperForum.com is a library of technical topics, airplane builds, images, technical manuals, technical documents and more.

    Access to PiperForum.com is subscription based. Subscriptions are only $49.99/year or $6.99/month to gain access to this great community and unmatched library of Piper knowledge.

    Click Here to Become a Subscribing Member and Access PiperForum.com in Full!

Slight miss in cruise

Greg S

Well-Known Member
Joined
Jan 6, 2011
Messages
434
Reaction score
16
I noticed something yesterday when my wife & I headed up north for lunch and to enjoy the weather. After climbing to cruise alt. - 4500' for this jaunt - I noticed what seemed to be a slight miss in the engine. Nothing extreme, just not the usual smooth running I've grown accustomed to. I seemed to be runing fine during climb, but when I leveled off and started to lean the mixture, I noticed it. Going to full rich didn't change anything. Fuel pump on - no difference. EGT was fine, RPM stayed constant. There were no other indications anything was amiss. It was annualled only about 10-15 hours ago and I know the plugs were cleaned and timing set. Run-up was fine with no problems with the mag checks.. I was thinking of just puling the plugs to check if 1 may have gotten fouled, but the engine has always ran fine . Any thoughts out there?
 

Latest posts

Top